Social Icons

twitterfacebookgoogle pluslinkedinrss feedemail


Friday, October 10, 2008

How to install AXDT plugin in Eclipse

I'm working with flex since a few month and really like flare project.
I cannot find a good IDE to work in a nice way, since I prefer open source solution I'm trying to leave Adobe IDE for a complete Eclipse solution.
AXDT seems a promising project, but had some problem in the installation on a 3.4 version of Eclipse so I'm posting it here a really short HowTo in case it could be usefull for others.

AXDT require IMP plugin to work and in the current version the dependancy is with version 0.1.75 of IMP.
Also IMP have dependancy so the best way to proceed is:

  1. Install Polyglot plugin as going to "Available Software" tab and using "Add Site"button to add Remember to restart Eclipse.
  2. Install LPG plugin as before (the update site is again remember to restart after installation completion.
  3. Now we can add IMP plugin and the upgrade site is And here it comes the third Eclipse restert (It may not be necessary, but it seems to me that Eclipse sometimes prefer to make just one installation per session so ...).
  4. Now is possible to install AXDT plugin and the update site is The last restart is needed to get to the flex work.

1 commenti:

ain said...

Installing LPG and Polyglot plugins separately isn't required as they're all bundled in IMP now. For Eclipse 3.5 (Galileo) the installation procedure is described in detail at AXDT: open-source cross-platform alternative for Flash development.

Several wiki pages of AXDT have been updated as well.